Slot zarezerwowany Wolny slot Wolny slot Wolny slot Wolny slot

Strefa czasowa: UTC + 1 [ DST ]






 Strona 1 z 2 [ Posty: 30 ]  Przejdź na stronę:  1, 2  Następna strona
Przeszukaj ten dział:
Autor Wiadomość
 #1   Tytuł: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 15 kwietnia 2018, 14:30 
Od pewnego czasu mam problem ze stacją GM330. Mianowicie chodzi o komunikacje z komputerem aby śledzić temperatury w czasie rzeczywistym. Stacja łączy się z komputerem na ułamek sekundy po czym wyskakuje komunikat " brak/błąd komunikacji sprawdź port COM" i następnie "sprawdź czy maszyna jest włączona" stacja działa bez problemu ale dopiero od niedawna postanowiłem podłączyć ją do komputera by mięć pełną kontrole. Na początku otrzymałem adapter USB-RS232 oparty na CH340 teraz nabylem UNITEK Y-105 oparty na Prolific pl2303 efekt ten sam. Wiem ze to działało, testów podłączyłem i użyłem programu PSoft Rework 2.2 na WinXP jakieś trzy lata temu. Teraz na Win7Pro adapterem Prolific program polecanym przez dystrybutora BGA Maintain Station niby zadziałało

I TU SIĘ DOPIERO ZACZĘŁO

"Niby" program komunikuje się ze stacją po wybraniu danego profilu i kliknięciu start maszyna startuje wskaźniki pomiarowe ruszają ale nic poza tym. Grzałki nie załączają. Na sterowniku PC410 miga dioda COM i RUN. Po próbie wysłania gotowych profili w programie wyskakuje komunikat ze jest OK jednak tak naprawdę nic to sterownika nie poszło.

Wysyłanie profili do stacji tez nie działa chociaż miga dioda COM. Co gorsze teraz nawet po odłączeniu stacji od komputera odczepieniu kabli nie działa z poziomu manualnego.
Mało tego testując teraz cała stacje manualnie dolna grzałka nie załącza wcale chodź czujnik temperatury działa prawidłowo (po przytrzymaniu temperatura rośnie na sterowniku REX C-100) głowica HR tez nie działa (działa tylko wiatrak) głowica IR działa ale na sterowniku zamiast temperatura rosnąć pokazuje malejącą aż ujemne (np -40 itd)

Proszę mi powiedzieć jak ma być ustawiony sterownik PC410 po przytrzymaniu przez 3-5s przycisku PAR/SET czyli ustawienia:

prog ; tunE ; AL1 ; ProP ; Int.t ; dEt.t ; H c.t ; Loc ; SP H ; SP L ; H PL ; SnbP ; OFSt ; C F ; Addr ; bAud ; ALo1 ; ALo2

Wszystkie te ustawienia zostały przepisane w tej kolejności jak występują w sterowniku PC410 SHANM.
Oraz jak ustawić prawidłowo sterownik REX C-100.

Może ktoś ma podobną stację lub zna się na tych sterownikach by podpowiedzieć jak przywrócić wszystko do normy.

POZDRAWIAM



 
 
 Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 15 kwietnia 2018, 14:30 
 
 
 
 #2   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 16 kwietnia 2018, 15:17 
Dzisiaj użyłem ustawień PSoft Rework z naszego forum ELVIKOM tj Addr: 0.1 ; bAud: 19.2 ; ALo2: HiAL i tak samo ustawienia com w Win7 profile zostały wgrane prawidłowo stacja ruszyła z tym ze dolny podgrzewacz zamiast tak jak go ustawiłem na 100C jechał dalej. Akcje zatrzymałem. Ponownie chciałem uruchomić wybrany profil i znowu to samo co wcześniej czyli stacja startuje ale bez efektu grzania.
Czy może być wadliwy/uszkodzony układ MAX232 na module RS232 w sterowniku PC410?

Pytanie jeszcze dlaczego stacja przestała działać w trybie manualnym (bez kompa). Działa wtedy jak trzymam przycisk start ale bez podgrzewacza dolnego.



 
 
 #3   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 16 kwietnia 2018, 21:16 
Hello!

Please, post a picture of PC410 and REX C-100 controllers, while the profile is running (after pressing to the Start button).



 
 
 #4   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 17 kwietnia 2018, 14:32 
Obrazek



 
 
 #5   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 17 kwietnia 2018, 23:57 
The PC410 controller does not enable the bottom heater.

Measure the voltage to ground on the highlighted pin (picture below) in the following caces:
a) Before pressing to the Start button.
b) After pressing to the Start button (while the profile is running).

Obrazek


You need to disassemble the PC410 controller. You just need to pull out the front board (no need to disassemble the rework machine).
For the test you just need to connect 230V mains power on pins 1 and 2 of controller and bridge the pins 14 and 15 of controller to simulate the Start button.

PC410 pinout:
Obrazek



 
 
 #6   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 18 kwietnia 2018, 10:57 
Tylko jak zrobię most 14 i 15 to tak jak bym trzymał START a wtedy PC-410 działa ale REX C-100 nie działa prawidłowo. Włącznik START jest impulsowy chyba że się mylę. Podłączenia są na pewno są ok bo nic nie ruszałem.

Obrazek



 
 
 #7   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 18 kwietnia 2018, 18:47 
radio790 napisał(a):
Tylko jak zrobię most 14 i 15 to tak jak bym trzymał START a wtedy PC-410 działa ale REX C-100 nie działa prawidłowo.
Kol. matic napisał, żebyś wyciągnął sterownik PC-410 z obudowy maszyny, zwarł piny 14 i 15 na sterowniku a potem podłączył go do ~230V i wykonał pomiar we wskazanym punkcie - sterownik ma być ODŁĄCZONY od maszyny na czas pomiarów.




_________________
Jeśli skorzystałeś z mojej pomocy na Forum, możesz w ramach podziękowania wspomóc jego rozwój.
Kliknij tutaj, aby dowiedzieć się więcej.
 
 
 #8   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 19 kwietnia 2018, 13:00 
a więc panie matic Po podłączeniu pod 230V rozlega się pisk (wyje buzer) i na wyświetlaczu jak na zdjęciu. Zwarcie pinu 14 i 15 nic nie zmienia. :( tak to nigdy się nie działo. Coś jest nie tak :(. Mimo tego dokonałem pomiaru 0,03v

Obrazek

ps. Vogelek23 tłumacz na forum działa prawidłowo tylko tak troszkę nawiązałem do efektu wciskania START



 
 
 #9   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 19 kwietnia 2018, 20:45 
On that picture the controller is in the "Run" state (after pressing to the Start button). The bottom heater enable output is also active, as it should be in "Run" state.

Remove the 230V, wait about 30 seconds, then try it again.

There is no buzzer in that controller. The buzzing sound could be caused by bad contact on 230V supply line. Check, if you have a good contact between the alligator clips and the pins 1 and 2 of the controller.



 
 
 #10   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 19 kwietnia 2018, 21:51 
matic napisał(a):
There is no buzzer in that controller.
Are you sure? Quote from ZM-DGC900 rework station user manual (it is based on the same PC410 controller):
Cytuj:
3. When desoldering BGA, turn the cooling fan to auto. After the temperature curve goes over, the buzzer alarms automatically.





_________________
Jeśli skorzystałeś z mojej pomocy na Forum, możesz w ramach podziękowania wspomóc jego rozwój.
Kliknij tutaj, aby dowiedzieć się więcej.
 
 
 #11   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 19 kwietnia 2018, 22:08 
Vogelek23 napisał(a):
matic napisał(a):
There is no buzzer in that controller.
Are you sure?
Yes, I'm 100% sure. There is no a buzzer inside the PC410 controller.

Vogelek23 napisał(a):
Quote from ZM-DGC900 rework station user manual (it is based on the same PC410 controller):
Cytuj:
3. When desoldering BGA, turn the cooling fan to auto. After the temperature curve goes over, the buzzer alarms automatically.
There is an external buzzer connected to the output "AL1" (pins 11 and 12) of the PC410 controller.



 
 
 #12   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 20 kwietnia 2018, 08:54 
Tak jest brzęczyk.
Obrazek
I właśnie jak podłącze bezpośrednio pod 230v to wyje a po wsadzeniu do maszyny przestaje i wraca do problemowej sytuacji. Czyli można ustawiać, komunikuje się z komputerem ale nie grzeje. Chyba że trzymam START to grzeje góra ale dół nie.

Martwi mnie więc zachowanie sterownika po podłączeniu pod 230v.
A może jest jakiś reset, ustawienia fabryczne? Może podczas prób podłączania pod komputer coś się poprzestawiało i wystarczy go zresetować w instrukcji nic takiego nie widzę ale może jest.



 
 
 #13   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 20 kwietnia 2018, 09:53 
It seems, the buzzer was subsequently solderd. Originally it is not present.

As I know, it is not possible to reset the controller to the factory default settings.
There are "PID settings", which was manually set for each model of rework machine.

Put the controller back to the machine and try to remove the wires from pins 9 and 10.
Are there any changes in operation, except that the connection to the PC does not work?



 
 
 #14   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 24 kwietnia 2018, 19:42 
Witam po przerwie. A więc po odczepieniu pin 9 i 10 bez zmian. Po naciśnięciu START bez reakcji. Gdy trzymam START stacja rusza bez podgrzewacza dolnego i po puszczeniu zatrzymuje się i utrzymuję temperaturę górnego.

po prostu oszalała

Następnie podłączyłem pin 9 i 10 podłączyłem do komputera ustawiłem profil maszyna odpaliła prawidłowo jednak temperatura dołu poszła w górę. Następnie coś w programie PSoft Rework zwariowało wskaźniki na PC pokazywały błędne pomiary dolne a w maszynie wszystko jak należy. Czas etapu 1 wydłużony ale maszyna przeszła do etapu 2 jednak czasy też wydłużone.

ODCZYTY W PC INNE NIŻ W MASZYNIE.

Po odłączeniu od komputera maszyna nie działa po naciśnięciu START tylko podczas trzymania.

Następnie znowu podłączam do PC startuje OK ale dolny podgrzewacz tym razem aż o 28C więcej niż należy. Proces zatrzymałem

Nie wiem co jest nie tak. Skoro nie ma ustawień fabrycznych jak na nowo ustawić PID?
POMOCY bo zamiast naprawiać stacja psuje :(

Poniżej fotorelacja
Obrazek

Obrazek

Obrazek

Obrazek

Obrazek

Obrazek

Obrazek

Obrazek

Obrazek



 
 
 #15   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 24 kwietnia 2018, 20:27 
Measure the resistance between pins 13 and 15 of PC410 controller in the following cases:
a) STOP button released.
b) STOP button pressed.

Measure the resistance between pins 14 and 15 of PC410 controller in the following cases:
c) START button released.
d) START button pressed.



 
 
 #16   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 24 kwietnia 2018, 21:40 
Pytanie odnośnie pomiaru START ? :

wciśnięty na np. 1s - pomiar
wciśnięty i trzymać - pomiar



 
 
 #17   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 24 kwietnia 2018, 21:50 
radio790 napisał(a):
Pytanie odnośnie pomiaru START ?
Pierwszy pomiar bez wciśniętego przycisku, drugi pomiar z przyciskiem wciśniętym na czas pomiaru, czyli trzymać.




_________________
Jeśli skorzystałeś z mojej pomocy na Forum, możesz w ramach podziękowania wspomóc jego rozwój.
Kliknij tutaj, aby dowiedzieć się więcej.
 
 
 #18   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 25 kwietnia 2018, 09:08 
Co miernik to inny pomiar ale najbardziej ufam UNI-T UT803. a więc:

stop zwolniony - 0
stop wciśnięty - miedzy 4 a 2Ω

start zwolniony - 0
start wciśnięty - 0,6 a 0,3Ω



 
 
 #19   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 25 kwietnia 2018, 19:35 
radio790 napisał(a):
- 0
What does it mean? 0Ω, or infinite (no resistance)?



 
 
 #20   Tytuł: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 25 kwietnia 2018, 21:52 
0 - brak pomiaru, odczyt zerowy tak jak bym trzymał sondy w powietrzu.

Dziś przyłapałem swoje dziecko jak klika w przyciski STOP START (stacja wyłączona). Generalnie jak stacja jest nie używana to jest odłączona od sieci. Ale coś mi się wydaje ze mogło tak klikać niejednokrotnie jak nie widziałem.

Czy mogło to coś uszkodzić??

jaki powinien być odczyt przy zwolnionym STOP/START na pinach 13 15 i 14 15?



 
 
 Tytuł: Re: Re: stacja GM330 (PC410 i REX C-100) odmawia posłuszeństwa
PostNapisane: 25 kwietnia 2018, 21:52 
 
 
 
Wyświetl posty nie starsze niż:  Sortuj wg  

Strefa czasowa: UTC + 1 [ DST ]

 Strona 1 z 2 [ Posty: 30 ]  Przejdź na stronę:  1, 2  Następna strona  
Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników
 Podobne tematy 
Konfiguracja PC410 oraz REX C10 w stacji SCOTLE IR6000.
Sterownik PC410 + ETC7420 i PSoft Rework - problem z temperaturami
Stacja BGA  [ROZWIĄZANY]
HP 6450b i stacja dokująca
Stacja lutownicza PT 803
Lutowanie rozpływowe, stacja lutownicza